Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The RabbitMQ Java client (com.rabbitmq:amqp-client) versions before 5.33.1 are vulnerable. A malicious AMQP server can declare an oversized string or bytes field length, causing the client to attempt a roughly 2 GB allocation before reading any data, which triggers an OutOfMemoryError that can crash the JVM (denial of service). The source says this is exploitable before authentication via the connection start server-properties table. Upgrade to version 5.33.1 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0073, the 54th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-68mj-5wr7-6fgg
- OSV: GHSA-68mj-5wr7-6fgg
- github.com/rabbitmq/rabbitmq-java-client/security/advisories/GHSA-68mj-5wr7-6fgg
- github.com/rabbitmq/rabbitmq-java-client/pull/2007
- github.com/rabbitmq/rabbitmq-java-client/pull/2008
- github.com/rabbitmq/rabbitmq-java-client/commit/388209356c6478088efce4d8a07b68e73837a7a0
- github.com/rabbitmq/rabbitmq-java-client/commit/6a87a8dcdc8b4cc4b961a7cdd388276446e5dfb2
- github.com/rabbitmq/rabbitmq-java-client
- github.com/rabbitmq/rabbitmq-java-client/releases/tag/v5.33.1