Advisory record · GHSA-68fv-2mgg-jv7q

source-map-js allows event-loop denial of service through indexed source-map section offsets

CVSS 8.7 HighEPSS 0.0046 · 39th percentile

Published by the GitHub Advisory Database at 18 Sept 2026, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
source-map-jsnpm>=1.0.0, <1.2.21.2.2
Identifiers
GHSA-68fv-2mgg-jv7q · CVE-2026-93749
Weakness (CWE)
CWE-1284
Published
18 Sept 2026
Updated
5 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The npm package source-map-js, versions from 1.0.0 before 1.2.2, does not validate the line offset value for each section of an indexed source map. An attacker who can get the application to process a crafted indexed source map can supply very large offset values that block the Node.js event loop for long periods, so the service cannot handle other requests. The fix is to upgrade source-map-js to version 1.2.2 or later.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.7 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N CNA (VulnCheck)
  • CISA KEV Not listed.
  • EPSS 0.0046, the 39th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:34 UTC First seen by agentprime
  2. 31 Oct 2026, 13:34 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.