Advisory record · GHSA-67c5-x5mf-rppq

MLflow: Improper Origin Validation in MLflow Assistant /ajax-api Endpoints Enables Browser-Mediated Local Command Execution

CVSS 9.6 CriticalCriticalEPSS 0.0038 · 32nd percentile

Critical, because:

  • CVSS score 9.6: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 19 May 2026, 12:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
mlflowPyPI>=3.9.0, <3.10.03.10.0
Identifiers
GHSA-67c5-x5mf-rppq · BIT-mlflow-2026-2611 · CVE-2026-2611 · PYSEC-2026-418
Weakness (CWE)
CWE-346 · CWE-940
Published
19 May 2026
Updated
5 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

MLflow versions 3.9.0 up to but not including 3.10.0 are affected. The MLflow Assistant /ajax-api endpoints do not properly validate request origin, so a user visiting a malicious webpage can have their browser send cross-origin requests to a locally running Assistant. This lets an attacker change the Assistant's configuration to full access and then run arbitrary commands through its Claude Code sub-agent. Upgrade to MLflow 3.10.0 or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.6 Critical 3.0 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H CNA (@huntr_ai)
  • CISA KEV Not listed.
  • EPSS 0.0038, the 32nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:09 UTC First seen by agentprime
  2. 31 Oct 2026, 14:09 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.