Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Nginx UI versions from 1.9.10-0.20250517140552-daee3ac7ade1 up to but not including 1.9.10-0.20260728114330-580585516dd8 verify self-upgrade binaries only against a SHA-512 digest served from the same origin, with no cryptographic signature check. An attacker who controls the download source, such as a compromised mirror or a man-in-the-middle on an HTTP proxy, can supply a malicious binary and matching digest, leading to code execution as root on upgrade. Upgrade to 1.9.10-0.20260728114330-580585516dd8 or later. The source gives few details on additional workarounds.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0018, the 6th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV