Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Contao's comments bundle (contao/comments-bundle) versions from 4.0.0 before 5.3.50, and from 5.4.0-RC1 before 5.7.12, is vulnerable to cross-site scripting. An unauthenticated front end visitor can submit a comment containing script that runs in the back end when a back end user opens the Comments module, even if the comment is unpublished, and the script could then act with that user's privileges. Upgrade to version 5.3.50 or 5.7.12, which are the fixed versions listed.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.3 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0028, the 20th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:54 UTC First seen by agentprime
- 31 Oct 2026, 13:54 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-628f-v4f6-p37r
- OSV: GHSA-628f-v4f6-p37r
- github.com/contao/contao/security/advisories/GHSA-628f-v4f6-p37r
- github.com/contao/contao/commit/22505d5f79bc1a7f52e2cba5fddf6007e1f0408a
- github.com/contao/contao
- github.com/contao/contao/releases/tag/5.3.50
- github.com/contao/contao/releases/tag/5.7.12