Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Python-Markdown versions before 3.8.1 (markdown package) are affected. Malformed HTML-like sequences in Markdown can make the HTML parser raise an unhandled AssertionError, so an attacker who can supply Markdown to an application can crash it, causing denial of service. Upgrade to markdown 3.8.1 or later. The source gives few details on the information disclosure claim.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0066, the 51st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:34 UTC First seen by agentprime
- 31 Oct 2026, 14:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-5wmx-573v-2qwq
- OSV: GHSA-5wmx-573v-2qwq
- nvd.nist.gov/vuln/detail/CVE-2025-69534
- github.com/Python-Markdown/markdown/issues/1534
- github.com/Python-Markdown/markdown/pull/1535
- github.com/Python-Markdown/markdown
- github.com/Python-Markdown/markdown/actions/runs/15736122892
- github.com/pypa/advisory-database/tree/main/vulns/markdown/PYSEC-2026-89.yaml
- www.openwall.com/lists/oss-security/2026/03/06/4