Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Concrete CMS packages affected by this advisory are concrete5/concrete5 versions before 9.5.1, with 9.5.1 as the fixed release. The endpoint for remote upgrades does not check a CSRF token, so an attacker who controls the remote package served for a marketplace item already installed on the site can get a logged-in administrator with package-install rights to visit a crafted page and trigger remote code execution as the web server user. The victim must be able to install packages and the site must be connected to the Concrete marketplace. Upgrade to Concrete CMS 9.5.1 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (ConcreteCMS) |
- CISA KEV Not listed.
- EPSS 0.0017, the 6th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:59 UTC First seen by agentprime
- 31 Oct 2026, 13:59 UTC Confirmed by OSV