Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Nginx UI versions before 1.9.10-0.20260703131214-23d1934099b0 have a flaw where the MCP configuration tools (the /mcp and /mcp_message endpoints, including nginx_config_add) skip the restricted directive validation that the HTTP configuration API applies. A secondary authenticated user with MCP enabled can therefore load NJS modules, import attacker-supplied JavaScript, and run it in the Nginx worker context, which can alter responses, routing, headers, and redirects. Upgrade to 1.9.10-0.20260703131214-23d1934099b0 or later. The source gives no workaround beyond the fix.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.3 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0028, the 20th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-5r62-gj48-897x
- OSV: GHSA-5r62-gj48-897x
- github.com/0xJacky/nginx-ui/security/advisories/GHSA-5r62-gj48-897x
- nvd.nist.gov/vuln/detail/CVE-2026-84319
- github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2
- github.com/0xJacky/nginx-ui
- github.com/0xJacky/nginx-ui/releases/tag/v2.4.1