Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GeoNetwork's gn-web-app Maven package is affected in versions 4.4.0 to before 4.4.12 and 4.0.0 to before 4.2.17. An unauthenticated attacker can use the SLD tool endpoint, which fetches a caller-supplied WMS server URL without validation, to make the server send requests to internal hosts and read back XML responses. Upgrade to 4.4.12 or 4.2.17.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.8 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.014, the 73rd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:18 UTC First seen by agentprime
- 31 Oct 2026, 14:18 UTC Confirmed by OSV