Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
pypdf versions before 6.21.1 are vulnerable. An attacker who can supply a crafted PDF can cause arbitrary image parsers to be called when the PDF's image is loaded, but only if the optional Pillow dependency is installed. Upgrade to pypdf 6.21.1 or later; the source gives no other workaround besides a pull request, which is not listed here.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 2.3 | Low | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0040, the 34th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-5hx5-vpf9-5wcv
- OSV: GHSA-5hx5-vpf9-5wcv
- github.com/py-pdf/pypdf/security/advisories/GHSA-5hx5-vpf9-5wcv
- nvd.nist.gov/vuln/detail/CVE-2026-113786
- github.com/py-pdf/pypdf/pull/4222
- github.com/py-pdf/pypdf/commit/512d8eb94eb04be1d1c90504e6da2dcef8679e07
- github.com/py-pdf/pypdf
- github.com/py-pdf/pypdf/releases/tag/6.21.1