Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Affected: vLLM versions >=0.23.0rc2 and <0.30.0, fixed in 0.30.0. An attacker who can send chat completion requests to a video-capable model can supply request-level video options that make the GLMGA sampler build and deduplicate very large index lists, even for a tiny video. This can consume CPU and memory and delay other media requests, causing partial denial of service. Upgrade vLLM to 0.30.0 or later. Workarounds include blocking request-level video options at a gateway, restricting untrusted callers from selecting GLMGA, and applying rate limits and concurrency limits.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0030, the 22nd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-58v5-2m8f-94pr
- OSV: GHSA-58v5-2m8f-94pr
- github.com/vllm-project/vllm/security/advisories/GHSA-58v5-2m8f-94pr
- github.com/vllm-project/vllm/pull/54935
- github.com/vllm-project/vllm/commit/8b6de0eb9a09ef53f20cf06bd4d17ee264b9c2a7
- github.com/vllm-project/vllm
- github.com/vllm-project/vllm/releases/tag/v0.30.0