Advisory record · GHSA-56xg-wfcc-g829

llama-cpp-python vulnerable to Remote Code Execution by Server-Side Template Injection in Model Metadata

CVSS 9.7 CriticalCriticalEPSS 0.26 · 97th percentile

Critical, because:

  • CVSS score 9.7: 9.0 or more.
  • CVSS score 9.7 (7.0 or more) and EPSS 0.26 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical

Published by the GitHub Advisory Database at 13 May 2024, 14:10 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
llama-cpp-pythonPyPI>=0.2.30, <0.2.720.2.72
Identifiers
GHSA-56xg-wfcc-g829 · CVE-2024-34359 · PYSEC-2026-392
Weakness (CWE)
CWE-76
Tags
Published
13 May 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

llama-cpp-python versions from 0.2.30 before 0.2.72 are affected. A model file with a malicious chat template in its metadata can trigger server-side template injection when the model is loaded and used, because the template is rendered without a sandbox. An attacker who can get a user to load such a model can execute arbitrary code. Upgrade to llama-cpp-python 0.2.72 or later.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.7 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.26, the 97th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.