Advisory record · GHSA-56v8-86gj-66jp

Spring Boot DevTools remote secret comparison is vulnerable to timing attacks

CVSS 7.5 HighEPSS 0.0026 · 18th percentile

Published by the GitHub Advisory Database at 28 Apr 2026, 00:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.springframework.boot:spring-boot-devtoolsMaven>=4.0.0, <4.0.6 || >=3.5.0, <3.5.14 || >=3.4.0, <=3.4.15 || >=3.3.0, <=3.3.18 || <=2.7.324.0.6, 3.5.14
Identifiers
GHSA-56v8-86gj-66jp · CVE-2026-40972
Weakness (CWE)
CWE-208
Published
28 Apr 2026
Updated
6 May 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Spring Boot DevTools (org.springframework.boot:spring-boot-devtools) versions 4.0.0 to before 4.0.6, 3.5.0 to before 3.5.14, 3.4.0 through 3.4.15, 3.3.0 through 3.3.18, and 2.7.32 and earlier are affected. An attacker on the same network as a remote application may be able to use a timing attack against its remote secret comparison and, in extreme cases, recover the secret and upload changed classes for remote code execution. Upgrade to 4.0.6 or 3.5.14; for the 3.4, 3.3 and 2.7 lines, the source lists fixed versions of 3.4.16, 3.3.19 and 2.7.33.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CNA (vmware)
  • CISA KEV Not listed.
  • EPSS 0.0026, the 18th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:20 UTC First seen by agentprime
  2. 31 Oct 2026, 14:20 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.