Advisory record · GHSA-563x-q5rq-57qp

Apache Tomcat has an HTTP Request/Response Smuggling vulnerability

CVSS 7.5 HighEPSS 0.0070 · 53rd percentile

Published by the GitHub Advisory Database at 9 Apr 2026, 21:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.apache.tomcat:tomcat-coyoteMaven>=7.0.0, <9.0.116 || >=10.1.0-M1, <10.1.52 || >=11.0.0-M1, <11.0.209.0.116, 10.1.52, 11.0.20
org.apache.tomcat.embed:tomcat-embed-coreMaven>=7.0.0, <9.0.116 || >=10.1.0-M1, <10.1.52 || >=11.0.0-M1, <11.0.209.0.116, 10.1.52, 11.0.20
Identifiers
GHSA-563x-q5rq-57qp · BIT-tomcat-2026-24880 · CVE-2026-24880
Weakness (CWE)
CWE-444
Published
9 Apr 2026
Updated
11 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Apache Tomcat (tomcat-coyote and tomcat-embed-core, Maven) is vulnerable to HTTP request smuggling through an invalid chunk extension in affected versions 7.0.0 through 9.0.115, 10.1.0-M1 through 10.1.52 and 11.0.0-M1 through 11.0.18, per the affected version ranges listed. The source does not describe the attacker's position or the exact impact beyond the smuggling class. Upgrade to 9.0.116, 10.1.52, 11.0.20 or a later fixed release.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.0070, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:16 UTC First seen by agentprime
  2. 31 Oct 2026, 14:16 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.