Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Versions of the xwiki-platform-rendering-parser Maven package from 6.0 up to 13.10.10, from 14.0 up to 14.4.6, and from 14.5 up to 14.9-rc-1 are affected. A user with write rights can insert deeply nested group content that makes the parser throw a StackOverflowError, which can make pages such as the user index and page index unusable. Upgrade to 13.10.10, 14.4.6, or 14.9-rc-1, depending on your release line. Increasing the JVM stack size with the -Xss parameter is a temporary workaround only, since it does not stop the issue from recurring with other content.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.011, the 65th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:18 UTC First seen by agentprime
- 31 Oct 2026, 14:18 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-52vf-hvv3-98h7
- OSV: GHSA-52vf-hvv3-98h7
- github.com/xwiki/xwiki-platform/security/advisories/GHSA-52vf-hvv3-98h7
- nvd.nist.gov/vuln/detail/CVE-2023-26479
- github.com/xwiki/xwiki-platform/commit/e5b82cd98072464196a468b8f7fe6396dce142a7
- github.com/xwiki/xwiki-platform
- jira.xwiki.org/browse/XWIKI-19838