Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
NATS Server (github.com/nats-io/nats-server/v2) versions before 2.11.14, and 2.12.0-RC.1 through 2.12.4, are vulnerable when leafnode connections are enabled. Before authentication, an attacker who can reach the leafnode port can crash the server with a panic by negotiating compression. Upgrade to 2.11.14 or 2.12.5. Alternatively, disable compression on the leafnode port.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0068, the 52nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:13 UTC First seen by agentprime
- 31 Oct 2026, 14:13 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-52jh-2xxh-pwh6
- OSV: GHSA-52jh-2xxh-pwh6
- github.com/nats-io/nats-server/security/advisories/GHSA-52jh-2xxh-pwh6
- nvd.nist.gov/vuln/detail/CVE-2026-29785
- github.com/nats-io/nats-server/commit/a1488de6f2ba6e666aef0f9cce0016f7f167d6a8
- advisories.nats.io/CVE/secnote-2026-04.txt
- github.com/nats-io/nats-server