Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
openapi-python-client versions before 0.29.1 can generate arbitrary Python code when processing a malicious OpenAPI document, and that code runs when the generated client is imported. An attacker who can supply the OpenAPI document to be processed can thereby execute code in the context of anyone who imports the resulting client. Upgrade to version 0.29.1 or later, and audit any code previously generated from untrusted documents.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.4 | High | 4.0 | CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0014, the 3rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-5293-mq8x-g3xj
- OSV: GHSA-5293-mq8x-g3xj
- github.com/openapi-generators/openapi-python-client/security/advisories/GHSA-5293-mq8x-g3xj
- nvd.nist.gov/vuln/detail/CVE-2026-105801
- github.com/openapi-generators/openapi-python-client/pull/1483
- github.com/openapi-generators/openapi-python-client/commit/1c99af478892e5bbe6583b92acba431c9dec9186
- github.com/openapi-generators/openapi-python-client
- github.com/openapi-generators/openapi-python-client/releases/tag/v0.29.1