Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The pypdf PDF library is vulnerable in versions before 6.21.3, where strict mode can use large amounts of memory when handling exceptions. An attacker who supplies a crafted PDF containing an invalid dictionary can trigger this excessive memory use. Upgrade to pypdf 6.21.3, which contains the fix; if upgrading is not yet possible, the source suggests applying the changes from the referenced pull request.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.1 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0022, the 12th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 29 Oct 2026, 21:17 UTC Confirmed by NVD
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-4vqv-7265-gm2w
- OSV: GHSA-4vqv-7265-gm2w
- github.com/py-pdf/pypdf/security/advisories/GHSA-4vqv-7265-gm2w
- nvd.nist.gov/vuln/detail/CVE-2026-119207
- github.com/py-pdf/pypdf/pull/4265
- github.com/py-pdf/pypdf/commit/64270258c0eced720f7960aecf8cef31afd39f8d
- github.com/py-pdf/pypdf
- github.com/py-pdf/pypdf/releases/tag/6.21.3