Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Vyper versions before 0.2.6 mishandle complex arguments such as multi-dimensional arrays or structs with non-base-type members, passed to internal or external functions, because the compiler assumes each subtype occupies 32 bytes. This corrupts the call stack and produces incorrect output. The source does not describe what an attacker would need beyond writing contracts that use such arguments. Upgrade to Vyper 0.2.6 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-4v7v-gqf9-ww2g
- OSV: GHSA-4v7v-gqf9-ww2g
- github.com/vyperlang/vyper/security/advisories/GHSA-4v7v-gqf9-ww2g
- github.com/vyperlang/vyper/issues/2183
- github.com/vyperlang/vyper/pull/2184
- github.com/vyperlang/vyper/commit/0be02b7331e8febe79d5a4218829c72e30417a29
- github.com/vyperlang/vyper
- github.com/vyperlang/vyper/releases/tag/v0.2.6