Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
RabbitMQ amqp091-go versions before 1.13.0 are vulnerable. A malicious or compromised AMQP server can send a frame with a crafted byte-array field length that causes an unrecovered runtime panic, crashing the client process. No fix is listed other than upgrading to 1.13.0, which is the fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.9 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0052, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:12 UTC First seen by agentprime
- 31 Oct 2026, 14:12 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-4v58-74mf-rjx3
- OSV: GHSA-4v58-74mf-rjx3
- github.com/rabbitmq/amqp091-go/security/advisories/GHSA-4v58-74mf-rjx3
- nvd.nist.gov/vuln/detail/CVE-2026-77412
- github.com/rabbitmq/amqp091-go/pull/344
- github.com/rabbitmq/amqp091-go/commit/669b42bf7b1db76bc6d4973e3634247f680accbf
- github.com/rabbitmq/amqp091-go
- github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0