Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's netty-codec-xml package is vulnerable in versions from 4.2.0.Final before 4.2.16.Final and from 4.1.0.Final before 4.1.136.Final. An attacker who can send bytes into a channel pipeline that uses XmlDecoder can submit XML with a DOCTYPE declaration, and the source says whether external entities are resolved depends on the Aalto XML parser's behavior, so exploitability is conditional. Upgrade to 4.2.16.Final or 4.1.136.Final. The source gives few details on the exact impact.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.3 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0069, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-4qhr-g3c6-fcfx
- OSV: GHSA-4qhr-g3c6-fcfx
- github.com/netty/netty/security/advisories/GHSA-4qhr-g3c6-fcfx
- nvd.nist.gov/vuln/detail/CVE-2026-56817
- github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b
- github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6
- github.com/netty/netty
- github.com/netty/netty/releases/tag/netty-4.1.136.Final
- github.com/netty/netty/releases/tag/netty-4.2.16.Final