Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's netty-codec-http package, versions 4.2.0.Final before 4.2.16.Final and before 4.1.136.Final, has a WebSocket V07/V08 handshaker that skips checking the Connection and Upgrade headers. A remote attacker can send a request with a WebSocket version header and no upgrade headers, which can complete a protocol switch that a proxy does not treat as an upgrade, enabling HTTP request smuggling and protocol-confusion attacks. Upgrade to netty-codec-http 4.2.16.Final or 4.1.136.Final.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0044, the 38th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV