Advisory record · GHSA-4hg4-9mf5-wxxq

incorrect order of evaluation of side effects for some builtins

CVSS 3.7 LowEPSS 0.0054 · 45th percentile

Published by the GitHub Advisory Database at 4 Sept 2023, 16:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vyperPyPI<0.3.100.3.10
Identifiers
GHSA-4hg4-9mf5-wxxq · CVE-2023-41052 · PYSEC-2023-168
Weakness (CWE)
CWE-670
Published
4 Sept 2023
Updated
17 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Vyper versions before 0.3.10 evaluate the arguments of the builtins uint256_addmod, uint256_mulmod, ecadd and ecmul out of source order, which matters when one argument has side effects that another depends on. An attacker would need to be able to supply or influence the contract source code being compiled, since the issue arises from how the compiler orders evaluation. The fix is to upgrade to Vyper 0.3.10. As a workaround, avoid side effects in arguments to these builtins, or make sure no other argument depends on them.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
3.7 Low 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0054, the 45th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:10 UTC First seen by agentprime
  2. 31 Oct 2026, 14:10 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.