Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Nodemailer versions from 3.0.0 before 10.0.13 are affected by a quadratic backtracking issue in the regular expressions that detect SMTP AUTH mechanisms in an EHLO response. A malicious or man-in-the-middle SMTP server can send a long whitespace run in an AUTH line, which blocks the Node.js event loop during the pre-authentication handshake, causing denial of service. The source says the fix is in version 10.0.13, so users should upgrade to nodemailer 10.0.13 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0037, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-4ffr-jq9g-5ffx
- OSV: GHSA-4ffr-jq9g-5ffx
- github.com/nodemailer/nodemailer/security/advisories/GHSA-4ffr-jq9g-5ffx
- github.com/nodemailer/nodemailer/commit/b5a896fcb02df1628329d7cd665ca08490b14b56
- github.com/nodemailer/nodemailer
- github.com/nodemailer/nodemailer/releases/tag/v10.0.13