Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
LiteLLM versions before 1.34.42 are vulnerable to server-side template injection through the /completions endpoint. The hf_chat_template method renders the chat_template value from tokenizer_config.json with Jinja without sanitization, so an attacker who can supply a malicious tokenizer_config.json could execute arbitrary code on the server. Upgrade litellm to version 1.34.42 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.0 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA (@huntr_ai) |
- CISA KEV Not listed.
- EPSS 0.013, the 69th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:35 UTC First seen by agentprime
- 31 Oct 2026, 14:35 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-46cm-pfwv-cgf8
- OSV: GHSA-46cm-pfwv-cgf8
- nvd.nist.gov/vuln/detail/CVE-2024-2952
- github.com/BerriAI/litellm/issues/2949
- github.com/BerriAI/litellm/pull/2941
- github.com/BerriAI/litellm/commit/8a1cdc901708b07b7ff4eca20f9cb0f1f0e8d0b3
- github.com/BerriAI/litellm
- github.com/BerriAI/litellm/blob/0d803e13798db40aa7463e64a6bafaee386424f5/litellm/proxy/proxy_server.py#L2087
- github.com/advisories/GHSA-46cm-pfwv-cgf8
- github.com/pypa/advisory-database/tree/main/vulns/litellm/PYSEC-2026-387.yaml
- huntr.com/bounties/a9e0a164-6de0-43a4-a640-0cbfb54220a4
- pypi.org/project/litellm