Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Nginx-UI (Go module github.com/0xJacky/Nginx-UI) versions from 1.9.10-0.20250517140552-daee3ac7ade1 up to, but not including, 1.9.10-0.20260728074558-95cd21b70814 are affected. The password login endpoint enforces a second factor only when a TOTP secret is configured, so an account protected only by a passkey can log in with its password alone. An attacker who obtains the password can gain full access, which in this product can lead to control of the managed nginx instance and host. Upgrade to 1.9.10-0.20260728074558-95cd21b70814 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.1 | High | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0041, the 35th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV