Advisory record · GHSA-442q-2j6p-642g

datamodel-code-generator vulnerable to arbitrary local file read via XSD `schemaLocation` (`xs:include`/`xs:import`) path traversal, with no remote-ref gate

CVSS 7.5 HighEPSS 0.0055 · 46th percentile

Published by the GitHub Advisory Database at 28 Jul 2026, 21:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
datamodel-code-generatorPyPI>=0.59.0, <0.62.00.62.0
Identifiers
GHSA-442q-2j6p-642g · CVE-2026-55390 · PYSEC-2026-3556
Weakness (CWE)
CWE-22 · CWE-200 · CWE-610
Published
28 Jul 2026
Updated
12 Aug 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The datamodel-code-generator package, versions 0.59.0 up to but not including 0.62.0, reads files named by XSD schemaLocation attributes in xs:include, xs:import, xs:redefine and xs:override without restricting them to the input directory. An attacker who can supply the input XSD can use ../ traversal or absolute paths to read arbitrary local files, and their contents can appear in the generated output. No authentication is needed, and no existing setting disables this. Upgrade to version 0.62.0 or later.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0055, the 46th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:40 UTC First seen by agentprime
  2. 31 Oct 2026, 14:40 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.