Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
CloudNativePG versions before 1.28.3, and 1.29.0 before 1.29.1, let a low-privileged database user who can plant objects in a scraped database escalate to PostgreSQL superuser and run OS commands in the primary pod. Upgrade to 1.28.3 or 1.29.1. Until then, avoid target_databases '*' and limit database ownership to trusted roles.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.4 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0048, the 41st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-423p-g724-fr39
- OSV: GHSA-423p-g724-fr39
- github.com/cloudnative-pg/cloudnative-pg/security/advisories/GHSA-423p-g724-fr39
- nvd.nist.gov/vuln/detail/CVE-2026-44477
- github.com/cloudnative-pg/cloudnative-pg/pull/10576
- github.com/cloudnative-pg/cloudnative-pg
- github.com/cloudnative-pg/cloudnative-pg/releases/tag/v1.28.3
- github.com/cloudnative-pg/cloudnative-pg/releases/tag/v1.29.1