Advisory record · GHSA-3x94-m842-937c

PhpSpreadsheet: XmlScanner Bypass via ISO-2022 Escape Sequences Allows XXE and Denial of Service

CVSS 8.8 HighEPSS 0.0063 · 50th percentile

Published by the GitHub Advisory Database at 27 Oct 2026, 15:38 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
phpoffice/phpspreadsheetPackagist>=4.0.0, <5.10.0 || >=3.3.0, <3.10.8 || >=2.2.0, <2.4.8 || >=2.0.0, <2.1.19 || <1.30.75.10.0, 3.10.8, 2.4.8, 2.1.19, 1.30.7
Identifiers
GHSA-3x94-m842-937c · CVE-2026-108358 · PKSA-96jv-mtjg-g2v8
Weakness (CWE)
CWE-611 · CWE-776
Published
27 Oct 2026
Updated
27 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

GHSA-3x94-m842-937c affects the phpoffice/phpspreadsheet Composer package in versions before 1.30.7, 2.0.0 up to 2.1.19, 2.2.0 up to 2.4.8, 3.3.0 up to 3.10.8, and 4.0.0 up to 5.10.0. The XML scanner misses DOCTYPE declarations when ISO-2022 escape bytes are inserted between their characters, so an attacker who can supply a crafted XLSX file can get entity definitions past the check. This enables denial of service through entity expansion on all PHP versions, and file read or SSRF in some configurations. Upgrade to 1.30.7, 2.1.19, 2.4.8, 3.10.8, or 5.10.0, depending on the release line in use.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.8 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:L/SI:N/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0063, the 50th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:53 UTC First seen by agentprime
  2. 31 Oct 2026, 13:53 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.