Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Symfony's http-foundation and symfony packages are affected in versions before 5.4.50, from 6.0.0 before 6.4.29, and from 7.0.0 before 7.3.7. The Request class can represent some URLs with a path that does not start with a slash, which can bypass access control rules built on that assumption. The source does not state what an attacker must do beforehand or the exact impact beyond this bypass. Upgrade to 5.4.50, 6.4.29, or 7.3.7, depending on your branch.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.3 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.014, the 72nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:03 UTC First seen by agentprime
- 31 Oct 2026, 14:03 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-3rg7-wf37-54rm
- OSV: GHSA-3rg7-wf37-54rm
- github.com/symfony/symfony/security/advisories/GHSA-3rg7-wf37-54rm
- nvd.nist.gov/vuln/detail/CVE-2025-64500
- github.com/symfony/symfony/commit/9962b91b12bb791322fa73836b350836b6db7cac
- github.com/FriendsOfPHP/security-advisories/blob/master/symfony/http-foundation/CVE-2025-64500.yaml
- github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2025-64500.yaml
- github.com/symfony/symfony
- symfony.com/blog/cve-2025-64500-incorrect-parsing-of-path-info-can-lead-to-limited-authorization-bypass