Advisory record · GHSA-3qwc-47jf-5rf7

eth-abi is vulnerable to recursive DoS

No CVSS score

Published by the GitHub Advisory Database at 5 Mar 2024, 14:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
eth-abiPyPI<5.0.15.0.1
Identifiers
GHSA-3qwc-47jf-5rf7
Weakness (CWE)
CWE-1285
Published
5 Mar 2024
Updated
1 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

eth-abi versions before 5.0.1 are vulnerable to a recursive denial-of-service issue. The source gives few details: it describes a recursive pointer problem and refers to a related advisory, but does not say what input triggers it or what the impact is beyond denial of service. Upgrade to eth-abi 5.0.1, which is listed as the fixed version.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

No source has published a CVSS score for this record yet.

  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:38 UTC First seen by agentprime
  2. 31 Oct 2026, 14:38 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.