Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's netty-handler package, versions 4.2.0.Final before 4.2.15.Final and versions before 4.1.135.Final, is affected. A flaw in the IPv6 subnet filter rule comparison (IpSubnetFilterRule.compareTo) uses the wrong operand in a bitwise AND, so an attacker can send traffic from addresses outside the configured subnet and bypass IPv6 access controls. Upgrade to 4.2.15.Final or 4.1.135.Final.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.1 | High | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0099, the 62nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-3qp7-7mw8-wx86
- OSV: GHSA-3qp7-7mw8-wx86
- github.com/netty/netty/security/advisories/GHSA-3qp7-7mw8-wx86
- nvd.nist.gov/vuln/detail/CVE-2026-44249
- github.com/netty/netty
- github.com/netty/netty/releases/tag/netty-4.1.135.Final
- github.com/netty/netty/releases/tag/netty-4.2.15.Final