Advisory record · GHSA-3qhf-m339-9g5v

MCP Python SDK vulnerability in the FastMCP Server causes validation error, leading to DoS

CVSS 8.7 HighEPSS 0.098 · 95th percentile

Published by the GitHub Advisory Database at 4 Jul 2025, 22:06 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
mcpPyPI<1.9.41.9.4
Identifiers
GHSA-3qhf-m339-9g5v · CVE-2025-53366 · PYSEC-2026-1616
Weakness (CWE)
CWE-248
Published
4 Jul 2025
Updated
16 Jul 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The mcp Python SDK, versions before 1.9.4, has a validation error in its FastMCP Server that can cause an unhandled exception when malformed requests are processed. An attacker who can send such requests to the server can make it return 500 errors and become unavailable until it is manually restarted. Upgrade mcp to version 1.9.4 or later. The source gives few details on the exact request conditions.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.7 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.098, the 95th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:42 UTC First seen by agentprime
  2. 31 Oct 2026, 14:42 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.