Advisory record · GHSA-3hcj-9m7p-wwm9

Gotify: Insufficiently Protected Password Change endpoint

CVSS 5.3 MediumEPSS 0.0034 · 27th percentile

Published by the GitHub Advisory Database at 15 Oct 2026, 20:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/gotify/server/v2Go<=2.9.1No fixed version yet
github.com/gotify/server/v3Go<3.0.03.0.0
Identifiers
GHSA-3hcj-9m7p-wwm9 · CVE-2026-102603 · GO-2026-6772
Weakness (CWE)
CWE-620
Published
15 Oct 2026
Updated
19 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Gotify server versions 2.9.1 and earlier (github.com/gotify/server/v2) and versions before 3.0.0 (github.com/gotify/server/v3) let the password change endpoint run without the current password. An attacker holding a valid client token can set a new password for the affected user, and recovery requires an administrator or direct database access. Upgrade the v3 module to 3.0.0, which requires re-authentication to change a password; no fixed version is listed for v2.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.3 Medium 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0034, the 27th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:11 UTC First seen by agentprime
  2. 31 Oct 2026, 14:11 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.