Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Canonical LXD versions from 4.0 before 5.21.4 and from 6.0 before 6.5, along with certain earlier Go module pseudo-versions, are vulnerable. An attacker with only read permission on a project can obtain WebSocket secrets from the operations API and use them to hijack another user's terminal or console session, running commands with that user's privileges; the attack depends on timing. Upgrade to LXD 5.21.4, 6.5, or the fixed pseudo-version 0.0.0-20250827065555-0494f5d47e41.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.4 | High | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N | CNA (canonical) |
- CISA KEV Not listed.
- EPSS 0.0021, the 11th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV