Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
yt-dlp versions from 2022.10.04 before 2023.11.14 are affected. A malicious website can use the Generic extractor to set an arbitrary proxy for requests yt-dlp makes, allowing a man-in-the-middle attack that may expose cookies not marked secure. Upgrade to yt-dlp 2023.11.14 or later; as a workaround, disable the Generic extractor with --ies default,-generic.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.0 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0032, the 25th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:36 UTC First seen by agentprime
- 31 Oct 2026, 14:36 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-3ch3-jhc6-5r8x
- OSV: GHSA-3ch3-jhc6-5r8x
- github.com/yt-dlp/yt-dlp/security/advisories/GHSA-3ch3-jhc6-5r8x
- nvd.nist.gov/vuln/detail/CVE-2023-46121
- github.com/yt-dlp/yt-dlp/commit/f04b5bedad7b281bee9814686bba1762bae092eb
- github.com/yt-dlp/yt-dlp
- github.com/yt-dlp/yt-dlp/releases/tag/2023.11.14