Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The npm package next, versions 16.0.0 up to but not including 16.3.8, is affected. A malicious website that a developer visits while running the development server can read sensitive development data, including the project's location on disk, source code snippets from error reports, the route list, and development logs, because the Model Context Protocol endpoint does not check which site a request comes from. Upgrade to next 16.3.8, which is the fixed version; production deployments do not serve this endpoint.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 2.3 | Low | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0011, the 1st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-39w2-rjm5-chcv
- OSV: GHSA-39w2-rjm5-chcv
- github.com/vercel/next.js/security/advisories/GHSA-39w2-rjm5-chcv
- nvd.nist.gov/vuln/detail/CVE-2026-94486
- github.com/vercel/next.js/commit/2d9f50a409312696145b82b3157aadb6b1fef476
- github.com/vercel/next.js
- github.com/vercel/next.js/releases/tag/v16.3.8