Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Two go-git modules are affected. The v6 module github.com/go-git/go-git/v6 is vulnerable from 6.0.0-alpha.1 before 6.0.0-alpha.3, and the v5 module github.com/go-git/go-git/v5 is vulnerable before 5.19.0. An attacker who can supply malformed commit or tag objects can cause go-git to parse them differently than upstream Git, and commit signing and verification run over reconstructed data, so a signature may appear valid for a commit whose metadata differs from the signed object. Upgrade v6 to 6.0.0-alpha.3 or v5 to 5.19.0. The source gives few details on the exact attack conditions.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.0 | High | 4.0 | CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0016, the 5th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:13 UTC First seen by agentprime
- 31 Oct 2026, 14:13 UTC Confirmed by OSV