Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Pydantic AI Harness (pydantic-ai-harness) versions before 0.59.0 do not enforce the tool-call limit on tools invoked from within run_code in the CodeMode toolset. An attacker who can influence the sandboxed program, including through prompt-injected content, can call tools past the operator's limit, including costly or side-effecting ones. Upgrade to pydantic-ai-harness 0.59.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0035, the 28th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-3589-pxp7-3gj8
- OSV: GHSA-3589-pxp7-3gj8
- nvd.nist.gov/vuln/detail/CVE-2026-114386
- github.com/pydantic/pydantic-ai/pull/10362
- github.com/pydantic/pydantic-ai/commit/eb27b2b89fe76ae23ee9b6fc9eb4b227a4967949
- github.com/pydantic/pydantic-ai
- github.com/pydantic/pydantic-ai/blob/v2.58.0/src/pydantic_ai_harness/pydantic_ai_harness/code_mode/_toolset.py#L642-L680
- github.com/pydantic/pydantic-ai/releases/tag/v2.59.0
- pypi.org/project/pydantic-ai-harness/0.59.0
- www.vulncheck.com/advisories/pydantic-ai-harness-before-0.59.0-codemode-tool-call-limit-bypass-via-run-code