Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
vLLM versions from 0.20.0 before 0.30.0 are affected by a denial of service flaw in the disaggregated /inference/v1/generate endpoint. A remote attacker can send inconsistent multimodal metadata, such as repeated or overlapping placeholder ranges or mismatched kwargs and hash lists, which produces a negative text span in Qwen2.5-VL position construction and crashes the engine. Upgrade vLLM to version 0.30.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0033, the 26th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV