Advisory record · GHSA-33rr-wq23-g6gg

Nginx-UI AuthRequired token cookie fallback enables CSRF against management APIs

CVSS 8.8 HighEPSS 0.0023 · 13th percentile

Published by the GitHub Advisory Database at 9 Oct 2026, 17:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/0xJacky/Nginx-UIGo>=1.9.10-0.20250517140552-daee3ac7ade1, <1.9.10-0.20260728074433-a3999bd78a3b1.9.10-0.20260728074433-a3999bd78a3b
Identifiers
GHSA-33rr-wq23-g6gg · CVE-2026-107809 · GO-2026-6703
Weakness (CWE)
CWE-352
Published
9 Oct 2026
Updated
19 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Nginx-UI (Go module github.com/0xJacky/Nginx-UI) versions from 1.9.10-0.20250517140552-daee3ac7ade1 up to, but not including, 1.9.10-0.20260728074433-a3999bd78a3b are affected. The authentication middleware accepts the API token from a browser cookie, so a remote attacker who lures a logged-in administrator to a malicious page can make cross-site state-changing requests, such as writing Nginx configuration and triggering reloads. Upgrade to 1.9.10-0.20260728074433-a3999bd78a3b or later; the source lists no workaround.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.8 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0023, the 13th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:11 UTC First seen by agentprime
  2. 31 Oct 2026, 14:11 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.