Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The amqp091-go library for Go, versions before 1.13.0, does not explicitly set a minimum TLS version when building the TLS configuration from amqps:// URIs, so it relies on the Go toolchain default. An attacker able to perform a man-in-the-middle attack could force a downgrade to TLS 1.0 or 1.1 when the client was built with a Go version earlier than 1.18, exposing message data and credentials. Upgrade to version 1.13.0 or later, which is the listed fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.4 | Critical | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0028, the 20th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:12 UTC First seen by agentprime
- 31 Oct 2026, 14:12 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-33mj-cw25-m34h
- OSV: GHSA-33mj-cw25-m34h
- github.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34h
- nvd.nist.gov/vuln/detail/CVE-2026-77405
- github.com/rabbitmq/amqp091-go/pull/355
- github.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6e
- github.com/rabbitmq/amqp091-go
- github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0