Advisory record · GHSA-32gq-x56h-299c

age vulnerable to malicious plugin names, recipients, or identities causing arbitrary binary execution

No CVSS score

Published by the GitHub Advisory Database at 18 Dec 2024, 18:23 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
filippo.io/ageGo<1.2.11.2.1
Identifiers
GHSA-32gq-x56h-299c · GO-2024-3344
Weakness (CWE)
CWE-25
Tags
Published
18 Dec 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The Go package filippo.io/age versions before 1.2.1 are vulnerable. A plugin name containing a path separator, supplied through an attacker-controlled recipient or identity string, can cause an arbitrary binary to be executed; on UNIX systems this also requires a directory matching the age plugin temporary path pattern to exist. Upgrade to version 1.2.1 or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

No source has published a CVSS score for this record yet.

  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:15 UTC First seen by agentprime
  2. 31 Oct 2026, 14:15 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.