Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
MLflow versions from 3.12.0rc0 before 3.17.0 are affected when the optional trulens and trulens-providers-litellm packages are installed on the tracking server. An unauthenticated attacker who can reach the server's scorer invoke endpoint can make it send an outbound HTTP request to an arbitrary host with attacker-chosen headers and body, which is a server-side request forgery. Upgrade mlflow to version 3.17.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0068, the 52nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-2wqp-q3c6-ccj5
- OSV: GHSA-2wqp-q3c6-ccj5
- github.com/mlflow/mlflow/security/advisories/GHSA-2wqp-q3c6-ccj5
- github.com/mlflow/mlflow/pull/25890
- github.com/mlflow/mlflow/commit/bac30b4148c4f40045b4d4db07ae60ab3838803f
- github.com/mlflow/mlflow
- github.com/mlflow/mlflow/releases/tag/v3.17.0