Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Shopware's shopware/core Packagist package is affected in versions below 6.6.10.9 and from 6.7.0.0 up to but not including 6.7.4.1. In these versions, a password reset link issued before a customer changes their email address remains valid, so someone who still holds that link, such as an attacker with access to the old email inbox, could reset the customer's password. Upgrade to 6.6.10.9 or 6.7.4.1, which are the fixed versions listed.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.0 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:L | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:03 UTC First seen by agentprime
- 31 Oct 2026, 14:03 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-2w46-vq8h-98vh
- OSV: GHSA-2w46-vq8h-98vh
- github.com/shopware/shopware/security/advisories/GHSA-2w46-vq8h-98vh
- github.com/shopware/shopware/commit/1338dd9a11e361639704bf8f09b6878552eb8c13
- github.com/shopware/shopware/commit/2fb94855696a90045b81c503d216ba7df8e64e52
- github.com/shopware/shopware
- github.com/shopware/shopware/releases/tag/v6.6.10.9
- github.com/shopware/shopware/releases/tag/v6.7.0.0
- github.com/shopware/shopware/releases/tag/v6.7.4.1