Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GeoNetwork's gn-web-app and gn-wfsfeature-harvester packages are vulnerable in versions 4.2.0 to before 4.2.13 and 4.4.0 to before 4.4.8. An unauthenticated attacker could exploit an XML External Entity flaw in the WFS indexing REST API endpoint to read sensitive files. Upgrade to 4.4.8 or 4.2.13. As a workaround, remove the gn-wfsfeature-harvester and gn-camelPeriodicProducer jars to disable WFS indexing.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 15:09 UTC First seen by agentprime
- 31 Oct 2026, 15:09 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-2p76-gc46-5fvc
- OSV: GHSA-2p76-gc46-5fvc
- github.com/geonetwork/core-geonetwork/security/advisories/GHSA-2p76-gc46-5fvc
- github.com/geotools/geotools/security/advisories/GHSA-826p-4gcg-35vw
- github.com/geonetwork/core-geonetwork/pull/8757
- github.com/geonetwork/core-geonetwork/pull/8803
- github.com/geonetwork/core-geonetwork/pull/8812
- github.com/geonetwork/core-geonetwork