Advisory record · GHSA-2mh5-3cw6-hrrq

Spring Cloud Config has an Authorization Bypass Through User-Controlled Key

CVSS 7.5 HighEPSS 0.0043 · 37th percentile

Published by the GitHub Advisory Database at 7 May 2026, 06:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.springframework.cloud:spring-cloud-config-serverMaven>=3.1.0, <=3.1.13 || >=4.1.0, <=4.1.9 || >=4.2.0, <=4.2.6 || >=4.3.0, <4.3.3 || >=5.0.0, <5.0.34.3.3, 5.0.3
Identifiers
GHSA-2mh5-3cw6-hrrq · CVE-2026-40981
Weakness (CWE)
CWE-639 · CWE-1220
Published
7 May 2026
Updated
11 Jun 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Spring Cloud Config server (org.springframework.cloud:spring-cloud-config-server) versions 3.1.0 through 3.1.13, 4.1.0 through 4.1.9, 4.2.0 through 4.2.6, 4.3.0 through 4.3.2, and 5.0.0 through 5.0.2 are affected when Google Secrets Manager is used as the backend. A client can craft a request that may expose secrets from GCP projects other than the intended one. Upgrade to 4.3.3 or 5.0.3; for the 3.1.x, 4.1.x and 4.2.x lines, the source says the fixed releases are available to Enterprise Support customers only.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CNA (vmware)
  • CISA KEV Not listed.
  • EPSS 0.0043, the 37th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:20 UTC First seen by agentprime
  2. 31 Oct 2026, 14:20 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.