Advisory record · GHSA-2jcm-hq8r-84wx

kafka-python prior to 2.3.2 contains a denial-of-service vulnerability in SCRAM authentication handling that allows a malicious or machine-in-the-middle broker to freeze the client event loop by su...

CVSS 8.7 HighEPSS 0.0052 · 44th percentile

Published by the GitHub Advisory Database at 10 Jun 2026, 22:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
kafka-pythonPyPI<2.3.22.3.2
Identifiers
GHSA-2jcm-hq8r-84wx · CVE-2026-10143 · PYSEC-2026-2191
Weakness (CWE)
CWE-400 · CWE-606
Published
10 Jun 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

kafka-python versions before 2.3.2 are vulnerable to a denial-of-service issue in SCRAM authentication. A malicious broker, or an attacker positioned in the middle of the connection, can supply an excessively large SCRAM iteration count that freezes the client event loop, blocking producers, consumers, admin operations and heartbeats. Upgrade to kafka-python 2.3.2 or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.7 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N CNA (VulnCheck)
  • CISA KEV Not listed.
  • EPSS 0.0052, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:10 UTC First seen by agentprime
  2. 31 Oct 2026, 14:10 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.