Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Excelize (github.com/xuri/excelize/v2) versions from 2.3.1 before 2.11.1-0.20260915055537-22f76f9acb94 are affected. A malformed OLE/CFB encrypted workbook passed to OpenFile, OpenReader or OpenBytes causes an unrecovered panic that terminates the calling process, and no password or authentication is needed. Upgrade to 2.11.1-0.20260915055537-22f76f9acb94 or later. The source gives few details on workarounds.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0024, the 15th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-2j4c-ffch-9f23
- OSV: GHSA-2j4c-ffch-9f23
- github.com/qax-os/excelize/security/advisories/GHSA-2j4c-ffch-9f23
- nvd.nist.gov/vuln/detail/CVE-2026-107214
- github.com/qax-os/excelize/pull/2395
- github.com/qax-os/excelize/commit/22f76f9acb94b85b3eb9c4365ab4f750cebbc565
- github.com/qax-os/excelize