Advisory record · GHSA-2hmj-97jw-28jh

Apache ZooKeeper: Insufficient Permission Check in AdminServer Snapshot/Restore Commands

CVSS 4.3 MediumEPSS 0.0034 · 27th percentile

Published by the GitHub Advisory Database at 24 Sept 2025, 12:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.apache.zookeeper:zookeeperMaven>=3.9.0, <3.9.43.9.4
Identifiers
GHSA-2hmj-97jw-28jh · BIT-zookeeper-2025-58457 · CVE-2025-58457
Weakness (CWE)
CWE-280
Published
24 Sept 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Apache ZooKeeper (org.apache.zookeeper:zookeeper) versions 3.9.0 through 3.9.3 are affected. An authenticated client with insufficient privileges can invoke the AdminServer snapshot and restore commands, which should require ALL permission on the root path, and so can obtain cluster state via snapshots. Upgrade to version 3.9.4, or disable the snapshot and restore commands or the AdminServer in the meantime.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
4.3 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.0034, the 27th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:17 UTC First seen by agentprime
  2. 31 Oct 2026, 14:17 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.